Opened 12 years ago

Closed 9 years ago

#991 closed defect (worksforme)

ASF Implementation bug (MPlayer could not reproduce an ASF file with two audio streams)

Reported by: damiox@… Owned by: reimar
Priority: very important Component: demuxer
Version: 1.0rc1 Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The MPlayer could not reproduce an ASF file that has two audio streams without a Mutex Object.
I mean, one audio stream has Inbound Audio, and the other audio stream has Outbound Audio, and it's not possible to hear correctly the audio, and the logs shows this:

============ ASF Stream group == END ===
Found movie at 0x1488 - 0x250D768
ASF: 2 audio and 1 video streams found
Auto-selected ASF audio ID = 1
Auto-selected ASF video ID = 3
ASF: Searching for audio stream (id:1).
VIDEO: [] 1024x768 16bpp 3.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:6 fourcc:0x0 size:1024x768 fps: 3.00 ftime:=0.3333

Attachments (1)

ASFSeekingBuggy.rar (125.7 KB) - added by damiox@… 12 years ago.
ASF Video example and its associated MPlayer log.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by damiox@…

ASF Video example and its associated MPlayer log.

comment:1 Changed 12 years ago by damiox@…

This is an ASF file that has one video stream and two audio streams.
The size of the video is big due to the ASF file's samples are not compressed.

comment:2 Changed 9 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:3 Changed 9 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

I am not really able to understand the problem description, but the ASF file seems to play fine for me, as well as switching between audio tracks.

Note: See TracTickets for help on using tickets.