Opened 11 years ago

Last modified 8 years ago

#1251 assigned enhancement

option -fixed-vo does not work

Reported by: orzel@… Owned by: reimar
Priority: normal Component: vo
Version: HEAD Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I want to start a loop with several *avi, and bypassing my default configuration (which is : left screen, fullscreen).
If i do only "mplayer *avi", and then put the window where i want (and not fullscreen), then, after each file, it will go back to its default behaviour (left screen, fs).

Then i've read about -fixed-vo, which seems to be exactly what i want, and did try : "mplayer -loop 0 -fixed-vo *"

But it wont work : for each file, the window is destroyed/re-created and the default behaviour is back. The doc says only some vo are supported, so i've checked with x11, gl, and xv, and none of them work as expeted.

I've tried the following versions from gentoo, with no fancy flag :
media-video/mplayer-1.0_rc2_p27120
media-video/mplayer-1.0_rc2_p27458

I'm using an ~amd64 installation of gentoo, fully updated.

The only case where i've managed to do what i want is by doing "mplayer file.avi -loop 0", with the 'loop' being at the end the important part, but then, of course, i have only one file :-(

Change History (9)

comment:1 Changed 11 years ago by compn

maybe you want -noconfig all to skip config ?

comment:2 Changed 11 years ago by orzel@…

No, this is not what I have described. using '-noconfig all' will just remove the config. But between each video, the window will quit and another one will be created (sure, with 'noconfig'), which is exactly what i want to avoid.

I want what the documentation states about -fixed-vo : no destroy/recreate of the window, so that it stays where i want, the way i want, when there is a change in the file being played.

comment:3 Changed 10 years ago by compn

mplayer -fixed-vo -loop 0 *avi
works fine with me for -vo directx

i move the window, the window stays put after files change.
gl/gl2 both change the position of the window for me (on windows), so i guess its not consistant behavior.

comment:4 Changed 10 years ago by beastd

  • Resolution set to invalid
  • Status changed from new to closed

Hi,

there is a little difference between the window is not recreated and
the window stays at the position the user interactively positioned it.
The former is definitely done for both Xv and OpenGL VOs. The window
is reused and also repositioned if not in fullscreen mode.

MPlayer VOs generally have much liberty in doing things their own way.
Though the differences were reduced several times for the major VOs, by
unifying implementation in shared source files.

Having said this, you could reopen and set severity level to enhancement
if like to have the behaviour you described.

For now you could also try using the `-geometry' option if this is possible
for your use case.

comment:5 Changed 10 years ago by orzel@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

erm! this definitely doesn't look like an 'improvement' to me, but actually bug... the window is not 'fixed'.

comment:6 Changed 10 years ago by beastd

  • Severity changed from normal to enhancement
  • Status changed from reopened to assigned

Please don't be upset!

I am already investigating how to get a uniform consistent behaviour for all
window VOs (or at least the X11 ones) that fits your demands and is consistent.

But still this is not a bug. To quote the manpage:
-fixed-vo

Enforces a fixed video system for multiple files (one (un)ini‐
tialization for all files). Therefore only one window will be
opened for all files. Currently the following drivers are
fixed-vo compliant: gl, gl2, mga, svga, x11, xmga, xv, xvidix
and dfbmga.

And please notice, the "fixed" is not in anyway associated with the window
position. This option has much wider scope and even drivers that don't even
have the concept of a user positionable window like the listed vo svga can implement it. The fixed is meant to describe the VO creation/destruction
behaviour and in the case of -fixed-vo it is created before the first clip
and destroyed after the last one as opposed to complete create/destroy cycle
for every clip.

comment:7 Changed 10 years ago by orzel@…

i'm not upset :) I just gave my opinion. Thanks for watching into this.
I understand the difference between 'window creation' and positionning..

comment:8 Changed 10 years ago by diogomfranco@…

(In reply to comment #3)

mplayer -fixed-vo -loop 0 *avi
works fine with me for -vo directx

i move the window, the window stays put after files change.

However, it still has #317, which isn't very nice of -fixed-vo :(

gl/gl2 both change the position of the window for me (on win

dows), so i guess

its not consistant behavior.

So does direct3d; and looking at the taskbar button shows that the window is destroyed / recreated, exactly what shouldn't happen with -fixed-vo; specially since those VOs are said to be compliant.

comment:9 Changed 8 years ago by compn

  • Owner changed from beastd to reimar
Note: See TracTickets for help on using tickets.